Reply
Newbie
Posts: 1
Registered: ‎06-08-2016

7A50T board UART problem

I am trying to follow the quickstart guide for the 7A50T board. I installed the UART driver from the link on the quickstart guide. It says it was sucessful and shows up under device manager. When I configure realterm to use this port with the 115200 8 bits 1 stop bit no parity settings mentioned in the quickstart guide I am unable to see any sucessful transmission when pushing switch 8. Also realterm is indicating that there is a "break" condition.

 

Any suggestions on how to get the UART to USB working for the demo on 7A50T eval board would be much appreicated

Avnet Employee (Super Contributor)
Posts: 80
Registered: ‎10-15-2014

Re: 7A50T board UART problem

Simple question but perhaps very inportant.  What bit file is loaded into the FPGA?  You need to insure that you have a design loaded that has a UART in it.

 

Nick

Nick Hartl
XDFAE
Visitor
Posts: 2
Registered: ‎04-20-2018

Re: 7A50T board UART problem

yes need to insure have a design and loaded that it does has a UAR yes ur correct .
Newbie
Posts: 1
Registered: ‎06-29-2018

Re: 7A50T board UART problem

The Artix-7 50T FPGA Evaluation Kit, designed by Avnet, is a completely customizable development kit perfect for embedded designers looking for a flexible, low-power platform. The Artix-7 50T FPGA evaluation board is a complete system, packaging all the necessary functions and interfaces needed for an embedded processor system onto a small footprint.