Reply
Visitor
Posts: 2
Registered: ‎11-09-2011

libxercesc

I just installed ISE 13.3 and several of the features such as Impact or even xinfo won't run and give the following system error:

"The program can't start because libxercesc.dll is missing from your computer.  Try reinstalling the program to fix this problem."

 

The file is there.  I have reinstalled multiple times and it does not help.  This looks like an issue with the PATH setting.

Does anyone have any advice?

Avnet Employee (Star Contributor)
Posts: 613
Registered: ‎04-20-2009

Re: libxercesc

I don't see anything similar to what you describe in the Xilinx Answer Database or in the Xilinx Community Forums.  You should consider opening a Xilinx Support Case since this is specifically related to the installation of their tools.

 

However, I'll provide some suggestions.

 

1) Are you using a supported O/S?

2) Did you install to the default path?  Or at least a path with no spaces?

3) Do you have Admin rights when you install?

4) If you are running stuff from the command-line, you are required to run a setup file first, by default in Windows located at C:\Xilinx\13.3\ISE_DS\settings<32/64>.bat

 

Bryan

Visitor
Posts: 2
Registered: ‎11-09-2011

Re: libxercesc

I am running Windows 7 Pro 64bit

I am installing to the default path

I installed with admin privledges

If I launch the ISE 64bit command prompt even xinfo fails to run.

 

I can launch ISE, but some of implementation processes fail.

 

I have entered a web case, but the issue has not been resolved yet.

 

Any help is appreciated.

Avnet Employee (Star Contributor)
Posts: 613
Registered: ‎04-20-2009

Re: libxercesc

Open a command prompt.  Goto C:\Xilinx\13.3\ISE_DS\ and then run settings64.bat.  After that, then try to run xinfo.  Does that work?

 

Do you have any previous Xilinx versions on this machine?  Are any of them in your path?  Do you have any Xilinx environment variables set?

 

Bryan