Reply
Regular Visitor
Posts: 9
Registered: ‎06-23-2009
Accepted Solution

PSoC firmware v1.1 and AVProg 3.41

In download section we can find latest version of AVProg (3.41). It needs PSoC firmware in version 1.1. For example my PSoC has v.1.0.1. I've tried to find new firmware to install it like guided in "s3aeval_restore...pdf", but i couldn't. On the other hand there is no older versions of AVProg available in download section, what is quite senseless. Or maybe i've missed something?

 

Regular Contributor
Posts: 31
Registered: ‎07-12-2009

Re: PSoC firmware v1.1 and AVProg 3.41

Check here in the forum

 

Byran from AVNET recently posted a new firmeware version for the PSoC

 

http://community.em.avnet.com/avnet/attachments/avnet/Spartan3A/107/1/Spartan3AEval_PSoC_Rev102b_pd5...

 

Greetings Totti

 

 

Regular Visitor
Posts: 9
Registered: ‎06-23-2009

Re: PSoC firmware v1.1 and AVProg 3.41

[ Edited ]

Thanks. I'll try that immediately Smiley Happy

 

...

 

Unfortunately, after loading posted .hex file to PSoC, there is same warrning form AvProg, that it needs firmware 1.1. Did anyone already tried that?


Avnet Employee (Regular Contributor)
Posts: 26
Registered: ‎04-22-2009

Re: PSoC firmware v1.1 and AVProg 3.41

The 3.4.1i installer creates a hierarchy under C:\Avnet\AvProg.   One of the folders there is titled PSoc_Firmware.   This is where you will find the latest hex file for the PSoC, compatible with the latest version of AvProg.

 

You have to use the mini-prog and Cypress PSoC programmer to update the Cypress chip.  If AvProg is still reporting version 1.0.1 is loaded, then your update of the PSoC failed for some reason.

Regular Visitor
Posts: 9
Registered: ‎06-23-2009

Re: PSoC firmware v1.1 and AVProg 3.41

Now everything works fine. And I understand now, why only latest veriosn is posted, when everything what you need is included. Anyway, thanks.

Avnet Employee (Star Contributor)
Posts: 612
Registered: ‎04-20-2009

Re: PSoC firmware v1.1 and AVProg 3.41

I had hoped to post some info before people started using this.  I posted the request to our web people last night, and they were faster at posting then I was at notifying you all.

 

As you have discovered, the new AvProg 3.4.1 does include a copy of the Rev 1.1.0 firmware.  The Rev 1.1.0 firmware is also available in the Restore S3A Eval archive.

 

AvProg 3.4.1 is not much different than 3.4.0 other than it requires the new firmware.  The Rev 1.1.0 has the following fixes/improvements compared to 1.0.1:

 

  • CapSense sensitivity greatly reduced so only a firm button push is registered as a push.  This issue also could cause intermittent resets when accessing the serial Flash.
  • Holding a CapSense button keeps the button asserted indefinitely
  • USB set for 3V chip operation rather than 5V.  Also changed to bus-powered, 500mA setting.
  • Corrected issue where CapSense buttons quit working when board was plugged into USB into a Windows PC with the driver installed but no applications connected to the virtual COM port
  • 12 MHz clock fixed

 

Let us know on the forum here if you find any issues.  For all of you that have board or will be getting boards within the next few months (as we clear out existing stock with the Rev 1.0.1 firmware), please follow the > Restoring the Spartan-3A Evaluation Kit to Its Original State tutorial to update the PSoC firmware.

 

Regards,

Bryan

Visitor
Posts: 4
Registered: ‎06-03-2009

Re: PSoC firmware v1.1 and AVProg 3.41

Hello all,

 

has anybody tried this firmware on Linux with AstriaEkiPro ? Does it work ?

 

Thank you,

Vaclav

Regular Contributor
Posts: 31
Registered: ‎07-12-2009

Re: PSoC firmware v1.1 and AVProg 3.41

Hi Vaclav,

 

yes it works... Smiley Happy

Did you  face any problems ?

 

Greetings

 

Totti

 

 

 

Visitor
Posts: 2
Registered: ‎11-26-2009

Re: PSoC firmware v1.1 and AVProg 3.41

Hi, When I tried to upgrade PSOC from Rev 1.0.1 to Rev 1.1 (following the steps exactly as specified in the document), I get following error. ========== Error message ====== Program Finished at 2:24:47 PM | | FAILED! Can not Acquire Device! Please verify the device connection to the Programmer Program Requested at 2:24:09 PM | Active HEX file set at 2:22:27 PM | C:\Program Files\Avnet\AvProg\PSoc_Firmware\Spartan3AEval_PSoC_Rev110_pd5sp45.hex Device set to CY8C24894-24LFXI at 2:18:22 PM | 16384 FLASH bytes Device set to CY8C24094-24AXI at 2:17:32 PM | 16384 FLASH bytes Device Family set to 24x94 at 2:17:32 PM | | Please navigate to the Utilities tab and click the Upgrade Firmware button Port Opened with Warnings at 2:16:58 PM | MINI version Expecting 1.77, but found 1.73 Opening Port at 2:16:57 PM | Device set to CY7C60113-PVXC at 2:14:36 PM | 8192 FLASH bytes Device Family set to 60100 at 2:14:36 PM | Session Started at 2:14:35 PM | PPCOM Version 5.0 ============================ Tried again, but same issue. What could be wrong?. Please let me know, any work-around. Thanks, Naveen
Avnet Employee (Star Contributor)
Posts: 612
Registered: ‎04-20-2009

Re: PSoC firmware v1.1 and AVProg 3.41

It sounds like you need to upgrade the firmware in your MiniProg:

   "MINI version Expecting 1.77, but found 1.73"

 

Did you try the suggestion to

   "Please navigate to the Utilities tab and click the Upgrade Firmware button"

 

PSoC Programmer has the ability to upgrade the firmware inside the MiniProg programming dongle.  That is what this error message is asking you to do.

 

Bryan