Reply
Visitor
Posts: 4
Registered: ‎05-16-2011

Wrong default FPGA firmware provided in downloads section

[ Edited ]

Here is the prompt generated after loading the downloaded firmware. Please note that the banner says "Serial Flash Test" while the banner in the quick start document says "Spartan 3A Eval demo". The serial flash test firmware does not seem to recognize any commands mentioned in the quick start. Please provide a download link for the "Spartan 3A Eval demo" bit file. Also please consider sharing the source code for the eval demo project.

 

*******************************************************************
*                    _____                                        *
*                   /     \                                       *
*                  /____   \____                                  *
*                 / \===\   \==/                                  *
*                /___\===\___\/  AVNET                            *
*                     \======/   ENGINEERING                      *
*                      \====/    SERVICES                         *
*                                                                 *
*       Spartan-3A Evaluation Kit -- Serial Flash Test            *
*******************************************************************
Avnet Spartan-3A Evaluation Kit
Serial Flash Test
AVT> help
Unrecognized command "help".
AVT>

Visitor
Posts: 4
Registered: ‎05-16-2011

Re: Wrong default FPGA firmware provided in downloads section

[ Edited ]

Please ignore the above message. I misunderstood the situation. I was using AvProg 4.0.5 and all the buttons on it other than Load were disabled so I clicked on Load assuming this would program the device with my bit file. But it appears load simply loads a "flash programmer" bit stream onto the fpga it does not load the specified bit file. The disabled buttons are enabled once the load operation is complete. You can now flash your bit file using the program button.