Reply
Avnet Employee (Star Contributor)
Posts: 511
Registered: ‎05-05-2009

Re: iMPACT:2246 JTAG problem

1) What JTAG programming cable are you using and how have you verified your JTAG cable is good.

2) It doesn't matter what JP2 configuration mode jumpers are set to when using the JTAG port to configure the FPGA. JTAG overrides the configuration mode pins.

Contributor
Posts: 11
Registered: ‎09-30-2013

Re: iMPACT:2246 JTAG problem

1) I am using:

platform cable usb II: model DLC10

Actually I am not sure if the cable is good or not, but I tried 3 cables, and I got the same error message, so I don't think that is a problem of jTAG cable.

2) My teacher tested the board, she found that if the jTAG cable isn't connected, pin 2 of J9 remains at 2.5V, but if she connect the cable, there is a voltage drop immediately, so cable usb cann't detect the board it think the boart isn't powered. But I don't know what can cause this problem? diode, capacitances, or maybe a open circuit somewhere? 

Avnet Employee (Star Contributor)
Posts: 511
Registered: ‎05-05-2009

Re: iMPACT:2246 JTAG problem

Please contact your local Avnet FAE and ask him to bring along his USB JTAG cable.

Avnet Employee (Star Contributor)
Posts: 511
Registered: ‎05-05-2009

Re: iMPACT:2246 JTAG problem

Also, please make sure you don't have another JTAG cable connected to the same PC you are using (two JTAG cables connected to the same PC).

Contributor
Posts: 11
Registered: ‎09-30-2013

Re: iMPACT:2246 JTAG problem

Thanks a lot.

I think I have to contact Avnet FAE, I did connect  just one JTAG with my PC. My teacher tested the board, we think it's a hardware problem, and more precisely maybe a power supply problem.

Thanks anyway