Reply
Contributor
Posts: 10
Registered: ‎02-27-2011

Device (driver) not recognized (need info).

 

Hello,


- We are currently working with the AES-S6PCIE-LX75T-G development kit
  on a Windows XP Professional 32-bit Computer, and all is working as
  expected.

  However, if looking in "Device Manager", the AES-S6PCIE-LX75T-G
  card seems to not be recognized by Windows !?
  On the "PCI Tree" application side, the AES-S6PCIE-LX75T-G" card is
  reported as a "Co-processor; Processor".

- Wondering what make the AES-S6PCIE-LX75T-G card not being recognized
  by Windows?
  Is it something missing on the FPGA side, or is it something
  missing on the driver side ?


- See the attached file ("device_not_recognize.PNG") for more details.


Any comment will be appreciated.

Claude Sylvain
Electro-Technica inc.

device_not_recognize.PNG
Avnet Employee (Super Contributor)
Posts: 79
Registered: ‎04-17-2009

Re: Device (driver) not recognized (need info).

What you see here is actually correct.  The configuration of the PCIe interface in the S6LX75T FPGA identifies the card as a 'Coprocessor', and this device ID must match the information in the device driver.  The device driver for the supplied PCIe Programmed I/O example design was first used with the Xilinx Spartan-3 1000 PCIe development board and has been used with many boards since then, so that is why Windows XP Device Manager identifies the device as a 'Spartan3-1000 PCIe I/O for Windows...'  Because 'Coprocessor' does not match any of the standard categories of devices in Device Manager (eg 'Disk drives', 'Display adapters', etc.), it is listed as 'Other devices'.  The software application that interacts with the S6LX75T board hardware (Avnet PCIe PIO Demo) is updated for each new board it is used with, but there is no reason to change the underlying software driver so it remains the same.

 

I hope this clears up any confusion. 

--
Tom Curran