Reply
Regular Contributor
Regular Contributor
Posts: 20
Registered: ‎03-04-2013
Accepted Solution

ISE/EDK 14.3: LwIP Demo failed

Hi,

I work on "LwIP Application Software 201" tutorial and I get the following message from demo_raw_apps.bat (see attached file): 'impact' is not recognized as an internal or external command.

Please make me advice, what should I do?

I use 30 days evaluation of the ISE 14.3  Embedded eddition which includes all required tools.

I can uograde to ISE 14.4 if it is required for this application, but I couldn't find XBD files for the 14.4 version.

Thank you in advance for your reply,

Ian

 

 

 

Avnet Employee (Star Contributor)
Posts: 180
Registered: ‎02-18-2010

Re: ISE/EDK 14.3: LwIP Demo failed

How are you launching XMD?  Try it  from the Start Menu --> 

 

Start Menu\Programs\Xilinx Design Tools\ISE Design Suite 14.3\Accessories

 

Open ISE Design Suite xx-Bit Command Prompt

 

Then run XMD

Regular Contributor
Regular Contributor
Posts: 20
Registered: ‎03-04-2013

Re: ISE/EDK 14.3: LwIP Demo failed

Thank you very much.

I launched command window from the ISE 14.3 tools and everything works now.

I mistakenly used before Microsoft command window instead of ISE command window.

 

Avnet Employee (Star Contributor)
Posts: 112
Registered: ‎06-09-2009

Re: ISE/EDK 14.3: LwIP Demo failed

[ Edited ]

Hi Ian,

 

I think that the error you see is related to the batch file being unable to locate the 14.4 tools on your system.  If you comment out the CLS command on line 23 of demo_raw_apps.bat and re-run it, I believe you will see some error messages about being unable to find the Xilinx settings32.bat or settings64.bat scripts that setup the command interpreter environment path back to the Xilinx tools so that XBD can be found.

 

I looked into the XBD files and I found that the 14.3 XBD that you have should be forwards compatible with the 14.4 tools.  However, the 14.4 LwIP Application Software 201 tutorial projects will not be backwards compatible to your 14.3 tools.

 

My best recommendation is to upgrade your tools to 14.4 and install the 14.3 XBD files in your 14.4 install folder.  This should give you the easiest path moving forward in completing the tutorial and running the demo.  If I remember correctly, your eval license should also be good for the newer version of Xilinx tools.

 

If you run into any problems, please let us know.

 

Regards,

 

-Kevin

Regular Contributor
Regular Contributor
Posts: 20
Registered: ‎03-04-2013

Re: ISE/EDK 14.3: LwIP Demo failed

Thank you very much for your message.

I successfully fininished all LwIP using ISE 14.3 Embedded edition.

Do you know, can I do this tutorial using ISE 14.3 Webpack + EDK on top of it ?

Best Regards,

Ian

 

 

Avnet Employee (Star Contributor)
Posts: 112
Registered: ‎06-09-2009

Re: ISE/EDK 14.3: LwIP Demo failed

Hi Ian,

I don't think you will be able to complete the portions that require you to generate a platform that uses MicroBlaze. For those you will need an Embedded or System Edition license.

Regards,

-Kevin
Newbie
Posts: 2
Registered: ‎10-21-2016

Re: ISE/EDK 14.3: LwIP Demo failed

Hi Ian
I am newbie in Lwip application. I am looking for file Lwip demo; however, i can't find on the Internet anymore to download it. I only found this document call: LwIP Application software 201 for the Spartan-6 LX9 MicroBoard.pdf
Please send me this demo to my email: lengoctai2010@gmail.com
Thank you so much!